Issue #124 [WontFix/closed] - Framework tutorial not running correctly

Posted by

What steps will reproduce the problem? 1.following the tutorial 2. 3. ...

WebIOPi version used? =>0.7.0

Python version used? =>2.7.3

Distro used? (WebIOPi has only been tested on Raspbian Wheezy) =>Raspbian

Raspberry Pi board revision? (1 or 2) =>2

For Javascript side bugs, Browser? =>Chrome, IE

Please provide any additional information below.

When I'm following the framework basis tutorial, I don't get the same result as it should. see attachment. Functions are OK, LED goes on and off but the button is not like it should. I have the same problem when I'm doing the macros tutorial.

Also when I add more than 3 buttons the same as from the Original framework tutorial I'm not able to control the GPIO. The button has a different color and will not do anything. I tried GPIO 7, 21, 24 etc. I set the config file like it was recommended.

Strange thing is that the layout of the button as described below, doesn't seem to be recognised. the tekst stays completely black in Geany. Am I missing a library or something like that?

<style type="text/css"> button { display: block; margin: 5px 5px 5px 5px; width: 160px; height: 45px; font-size: 24pt; font-weight: bold; color: white; }

            #gpio17.LOW {
                    background-color: Black;

            #gpio17.HIGH {
                    background-color: Blue;


Stefan van Amerongen

Files attached

Comment 1

Posted by trouch