Issue #022 [Duplicate/closed] - UnicodeDecodeError when page is loaded

Posted by macecchi

Hi. I am running a Webiopi server inside a Python script and using a custom index.html.

After I uploaded from 0.5.1 to 0.5.3, everytime the page finishes loading from a browser, I get a UnicodeDecodeError on the terminal from where I ran the script. The page is loaded normally, though, and the server keeps running.

Here it is what I get:

Traceback (most recent call last): File "/usr/lib/python2.7/", line 284, in _handle_request_noblock self.process_request(request, client_address) File "/usr/lib/python2.7/", line 310, in process_request self.finish_request(request, client_address) File "/usr/lib/python2.7/", line 323, in finish_request self.RequestHandlerClass(request, client_address, self) File "/usr/lib/python2.7/", line 638, in __init__ self.handle() File "/usr/lib/python2.7/", line 340, in handle self.handle_one_request() File "/usr/lib/python2.7/", line 328, in handle_one_request method() File "/usr/local/lib/python2.7/dist-packages/WebIOPi-0.5.3-py2.7-linux-armv6l.egg/", line 469, in do_GET self.processRequest() File "/usr/local/lib/python2.7/dist-packages/WebIOPi-0.5.3-py2.7-linux-armv6l.egg/", line 466, in processRequest raise e UnicodeDecodeError: 'utf8' codec can't decode byte 0xff in position 62: invalid start byte

Any thoughts? PS: This also happens when I run the default index.


Comment 1

Posted by trouch

already fix on r728 see issue 20 please wait for next release or checkout repository