Issue #077 [WontFix/closed] - Address already in use

Posted by samuel.lh116

What steps will reproduce the problem? 1. 2. 3. ...

WebIOPi version used? =>0.6.0

Python version used? =>26

Distro used? (WebIOPi has only been tested on Raspbian Wheezy) =>Raspbian

Raspberry Pi board revision? (1 or 2) =>2

For Javascript side bugs, Browser? =>Chrome

Please provide any additional information below. Had an older version which worked fine then downloaded 0.6.0 and deleted old version Now comes up with 'socket.error: [Errno 98] Address already in use'

Comment 1

Posted by trouch

You should stop webiopi before removing/upgrading it. Reboot your pi.

Comment 2

Posted by samuel.lh116

rebooted and still doesn't work

Comment 4

Posted by trouch

use "sudo netstat -antp" and "sudo ps aux" to find out which process is using your port 8000 then kill it / change config.

Comment 5

Posted by trouch

I think you need to rewrite a bit your custom webiopi script. See\_Basis You don't need to instantiate webiopi Server in your script.